Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre courriel d'activation?
*


3 problèmes d'affichage suivant la langue


Pages: [1]
  Imprimer  

  3 problèmes d'affichage suivant la langue
Auteur Message
Pzmeyer
Nouveau membre
*

Points gagnés: 0
Messages: 9


Voir le profil
3 problèmes d'affichage suivant la langue
« le: 05 Février 2009 à 12:01:56 »

Bonjour à tous!
Voilà, nous avons installé Zen Cart pour le catalogue de notre site et nous avons plusieurs petits problèmes d'affichage.

Le Premier concerne les articles affichés sur l'index dans "NOUVEAUX PRODUITS" où comme vous pouvez le constater : http://lvs-shop.lavoiestrategique.com
les articles des deux langues s'affichent (pour un article identique il s'affiche en français et en anglais)... comment résoudre ce problème?... Si qlq'un a une idée?

Deuxième problème : une seule image s'affiche lorsqu'on sélectionne un article en français, alors qu'en anglais toutes les images d'un produit s'affichent (lorsqu'il y en a plusieurs bien sûr)... comme par exemple : http://lvs-shop.lavoiestrategique.com/index.php?main_page=product_info&cPath=80&products_id=203 Je trouve ça étrange...

Troisième et dernier (?) problème : les options de taille, couleur, etc. n'apparaissent pas en version anglaise (alors qu'en français oui)...

Si vous aviez une idée pour résoudre ces petits mais désagréables problèmes, nous vous serions reconnaissant!
Merci
Journalisée
jean-luc
Modérateurs
Intarissable
*****

Points gagnés: 3
Messages: 1561



Voir le profil WWW
Re : 3 problèmes d'affichage suivant la langue
« Répondre #1 le: 05 Février 2009 à 20:05:27 »

Bonsoir,

vu de loin il semblerait que les attributs soient définis dans une langue et pas dans l'autre d'où les problèmes.
Journalisée

jean-luc Evil or Very Mad

pas bon, mais promis j'essaye de m'améliorer tous les jours Evil or Very Mad

www.anneg-lingerie.com
Pzmeyer
Nouveau membre
*

Points gagnés: 0
Messages: 9


Voir le profil
Re : 3 problèmes d'affichage suivant la langue
« Répondre #2 le: 05 Février 2009 à 21:04:33 »

Bonsoir.
Pour les attributs qui ne s'affiche pas en anglais (taille, couleur, etc.), c'est ce que je pensais.
Mais pour le problème avec les images qui ne s'affichent pas toutes en français (alors que oui en anglais),
et pour le problème d'affichage dans "Nouveaux Produits",
je ne pense pas que le problème viennent des attributs...
Merci de votre attention.
Journalisée
Emma
Modérateurs
Espoir
*****

Points gagnés: 0
Messages: 238


Voir le profil WWW
Re : 3 problèmes d'affichage suivant la langue
« Répondre #3 le: 06 Février 2009 à 11:36:28 »

Bonjour

Pour l'affichage des images supplémentaires dans la version en français, c'est encore et toujours le même problème Javascript sur le groupe de mots "Agrandir l'image". L'apostrophe entre l et image bloque la lecture du script, et donc l'affichage des images.
Il faut donc modifier ce groupe de mots par "Agrandir l\'image".

Pour les nouveaux produits, il faudrait vérifier quand même les attributs, parce qu'il semblerait que ça affiche aléatoirement les produits dans les deux langues ?
Journalisée
Pzmeyer
Nouveau membre
*

Points gagnés: 0
Messages: 9


Voir le profil
Re : 3 problèmes d'affichage suivant la langue
« Répondre #4 le: 06 Février 2009 à 12:20:23 »

Bonjour,
tout d'abord merci beaucoup.
Effectivement, le problème de l'affichage des images vient bien de cette apostrophe. En fait, dans le code, il était déjà avec le backslash : "l\'image", alors j'ai carrément enlevé le mot... Il n'y a plus qu'Agrandir. Ca marche très bien.

Par contre, pour les Nouveaux Produits, je ne vois pas ce que je dois modifier dans les attributs et où, pour corriger le problème?... car effectivement, ça affiche aléatoirement les produits dans les deux langues...
Journalisée
Emma
Modérateurs
Espoir
*****

Points gagnés: 0
Messages: 238


Voir le profil WWW
Re : 3 problèmes d'affichage suivant la langue
« Répondre #5 le: 06 Février 2009 à 12:33:19 »

Vérifier les paramétrages dans la configuration ?
Journalisée
Pzmeyer
Nouveau membre
*

Points gagnés: 0
Messages: 9


Voir le profil
Re : 3 problèmes d'affichage suivant la langue
« Répondre #6 le: 06 Février 2009 à 12:45:29 »

euh, oui... mais je ne vois pas ce que je dois changer...

La liste des "paramètres des Attributs" dans Configuration propose seulement ceci :

- Activer téléchargements     true     
- Télécharger avec redirection    true 
- Télécharger en streaming    false
- Expiration téléchargements (Nombre de jours)    7 
- Nombre de téléchargements autorisés - Par produit    5 
- Gestionnaire téléchargements, valeur des états de commande    4 
- Gestionnaire téléchargements, valeur des états de commande >= valeur basse    2 
- Gestionnaire téléchargements, valeur des états de commande <= valeur haute    4
- Activer le facteur de prix    true
- Active les remises de prix sur Qté    true
- Active les attributs Images    true 
- Active le texte de prix par mot ou lettre    true
- Texte du Prix - Espaces gratuits    1
- Type d'option ReadOnly - Ignorer les ajouts au panier    1 
   
Journalisée
Emma
Modérateurs
Espoir
*****

Points gagnés: 0
Messages: 238


Voir le profil WWW
Re : 3 problèmes d'affichage suivant la langue
« Répondre #7 le: 06 Février 2009 à 14:49:54 »

Non, je pensais à la configuration/new listing.
Si tu mets Display Product Description sur Off, ça supprime l'affichage du descriptif. Ca ne règle pas vraiment le souci de l'affichage aléatoire dans les deux langues, quoique ?
Journalisée
Pzmeyer
Nouveau membre
*

Points gagnés: 0
Messages: 9


Voir le profil
Re : 3 problèmes d'affichage suivant la langue
« Répondre #8 le: 06 Février 2009 à 16:04:08 »

Ben... en fait c'est bizarre: j'ai mis la description des nouveaux produits sur 0, mais ça l'affiche toujours.
J'ai même mis toutes les descriptions à 0 (produits phares, etc.), mais rien n'y fait. Sur la page principale, la deciption (environ 25 lettres) y est toujours et le problème avec l'affichage multi persiste toujours...
Journalisée
Emma
Modérateurs
Espoir
*****

Points gagnés: 0
Messages: 238


Voir le profil WWW
Re : 3 problèmes d'affichage suivant la langue
« Répondre #9 le: 06 Février 2009 à 21:39:20 »

Ha. Est-ce que le texte qui apparait correspond bien à la description de la fiche produit ?
Journalisée
Pzmeyer
Nouveau membre
*

Points gagnés: 0
Messages: 9


Voir le profil
Re : 3 problèmes d'affichage suivant la langue
« Répondre #10 le: 07 Février 2009 à 23:08:12 »

Désolé, j'étais absent depuis hier soir...
Pour répondre à la question : oui, le texte correspond au produit de l'image affiché de la fiche produit.
Mais la description pour un produit donné est en français et l'autre en anglais (le même produit qui s'affiche en double)..., mais lorsqu'on clique sur l'un deux on tombe sur la page du descriptif de la langue choisit (normal).
Journalisée

Pages: [1]
  Imprimer  
 

Aller à: