Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre courriel d'activation?
*


Migration site zencart : bugs inexplicables...


Pages: [1]
  Imprimer  

  Migration site zencart : bugs inexplicables...
Auteur Message
hezed
Nouveau membre
*

Points gagnés: 0
Messages: 13


Crazy mad cat


Voir le profil
Migration site zencart : bugs inexplicables...
« le: 28 Juin 2008 à 12:11:57 »

Bonjour à tous...

Je viens de basculer dans la 4ème dimension...

Résumé des faits :

Je réalise pour un ami la maquette d'un site sous Zencart 1.3.8a ("francisée") hébergée sur mon compte chez 1&1.
Ma maquette fonctionne, au niveau technique tout est ok, j'ai modifié un peu les css mais rien de bien méchant.

On envisage alors la migration de la maquette vers l'emplacement définitif du site, sur le compte de mon ami également chez 1&1 avec le même type de pack.

J'installe donc la même version de zencart (1.3.8a "francisée"), je migre les données de la base mysql de la maquette vers celle définitive (créée avec les même paramètres que l'autre), j'upload tous les fichiers (sauf les configure.php) de la maquette vers le site définitif, et là...

Arghhh :

- au niveau du template, c'est une des mes précédentes modifs du css qui est prise en compte, et pas la dernière...  Shocked

- pas un seul produit référencé (j'en ai rentré plus de 50 dans la maquette !)...

- le plus bizarre : la base de données de la maquette comporte 104 tables, celle du site définitif 198...????????????????

Pourtant, lorsque je vais sur les infos serveur depuis le menu outil de l'espace admin, j'ai pourtant bien les mêmes infos de serveur...

 Shocked Shocked Shocked

J'ai essayé de remodifier le template, rien à faire, pourtant les chmod sont bien à 777, mais même après avoir vidé tous mes caches, il ne me prend pas les modifs.
J'ai refait l'install depuis le début, idem.

Au secours !!!!

pour info et visu, les url de la maquette et du site définitif :
ATTENTION : je n'ai pas encore mis de disclaimer, mais c'est un site de vpc pour adultes...

maquette : http://www.hezed.net/luxuria
le site "définitif" : http://www.luxuria-shop.fr

MERCI d'avance à tous ceux qui auront une idée ou, encore mieux, la solution !
Journalisée

Comfortably numb.
damien
Administrateurs
Acharné
*****

Points gagnés: 4
Messages: 365


Voir le profil WWW
Re : Migration site zencart : bugs inexplicables...
« Répondre #1 le: 28 Juin 2008 à 18:44:43 »

Bonjour,

Oula bizarre le nombre de tables, il y a moins de 100 sur la version fr de base.
Etes-vous sûr qu'il n'y avait pas deja des tables dans du le serveur définitif, et que tout ceci se serait un peu mélangé ? configuré

D'autre part, attention à bien reconfiguré la boutique sur le template que vous avez fait dans l'administration (mais ca je pense que vous l'avez fait), et uploadez bien le répertoire de votre template qui est dans includes/templates/ après l'installation de la nouvelle boutique.

Vérifiez aussi si vous avez quelque chose dans la table "products" de la nouvelle boutique. Si oui, faites attention d'avoir bien transféré toutes les tables relatives aux produits et aux catégories (car s'il n'y a aucune catégorie, il est possible que les produits ne s'affichent pas non plus).
Journalisée

Cordialement,
Damien
hezed
Nouveau membre
*

Points gagnés: 0
Messages: 13


Crazy mad cat


Voir le profil
Re : Migration site zencart : bugs inexplicables...
« Répondre #2 le: 28 Juin 2008 à 22:32:30 »

Merci Damien  Very Happy, grâce à toi j'ai déjà un début d'explication... Mes tables "product" et "categories" sont tout simplement vides ! Comme ma requête sql d'importation des données semblait s'être correctement terminée, je n'avais pas jugé bon d'aller voir de plus près... Grosse erreur de ma part...(mais alors, où sont passés les 196 entrées que le rapport de requètes m'a indiqué avoir importé ?  Shocked)
Me rest plus qu'à refaire la migration de ces deux tables (bizarrement, le reste des tables est ok, je viens de vérifier)
Ce qui est aussi étrange, c'est que dans la bd de la maquette, la table "configuration" n'existe pas (pourtant le site fonctionne...Arf Moi plus rien comprendre, là...)

Reste que pour le css...  Confused J'ai beau creuser, je vois pas, je vais aller tenter ma chance dans la partie "personnalisation" du forum, peut-être que je trouverais une piste...

Merci encore à toi !!! Very Happy
Journalisée

Comfortably numb.
jacques
Nouveau membre
*

Points gagnés: 0
Messages: 2


Voir le profil
Re : Migration site zencart : bugs inexplicables...
« Répondre #3 le: 01 Octobre 2008 à 17:36:32 »

Bonjour,

Hezed, j'ai également un site pour lequel je voudrais installer une page Disclaimer. Peux-tu me dire comment tu as procédé.

D'avance merci

Cordialement  Jacques
Journalisée
hezed
Nouveau membre
*

Points gagnés: 0
Messages: 13


Crazy mad cat


Voir le profil
Re : Migration site zencart : bugs inexplicables...
« Répondre #4 le: 14 Octobre 2008 à 15:07:36 »

Bonjour Jacques,

Pour le disclaimer, j'ai rusé : j'ai installé zencart dans un dossier différent de la page du disclaimer. Ensuite, le visiteur est dirigé vers le bon dossier.
En mettant le disclaimer en index à la race de mon espace web, lorsqu'on entre l'url du site, on atterri donc sur le cette page, et lorsqu'on clique sur "ok", on arrive sur l'index zencart...

Euh, je ne suis pas sûre d'avoir été très claire...
Je reprend :
j'ai mis le disclaimer ici : www.mondomaine.com/index.php
il renvoie vers l'index zencart ici : www.mondomaine.com/boutique/index.php

Euh... C'est mieux, non, comme ça ?

Le problème (d'ailleurs, si tu trouve une solution, je suis preneuse), c'est que si le visiteur n'utilise pas la voie "normale" mais passe directement par /boutique, le disclaimer n'apparaît pas.
Je pense qu'on doit pouvoir y remédier avec des tests sur les sessions zencart, mais je n'ai pas pris le temps de me pencher dessus...
A voir !

Journalisée

Comfortably numb.

Pages: [1]
  Imprimer  
 

Aller à: