Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre courriel d'activation?
*


Quasi Résolu !! Problème avec checkout_shipping et chronopost.php


Pages: [1]
  Imprimer  

  Quasi Résolu !! Problème avec checkout_shipping et chronopost.php
Auteur Message
mchamps013
Nouveau membre
*

Points gagnés: 0
Messages: 3


Voir le profil
Quasi Résolu !! Problème avec checkout_shipping et chronopost.php
« le: 26 Février 2009 à 17:56:25 »

Bonjour,

je viens d installer Zen Cart 1.3.8a  sur mon site de vente. http://www.supporteurope.com/shop

je n'ai eu aucun problème lors de l instalation.
j ai installé les modules de langues: francais et espagnol.
j'ai rentré tout mes articles dans la base de donnée.
j'ai changé les banières de publicité, et j ai modifier le .css pour avoir diferentes couleurs de fond et d'écritures.
je n ai rien changé quant à la position de élément d'affichage.
je me suis inscrit pour faire un premier test d'achat.
Tout va bien ---

je choisis un article, et quand je suis dans mon panier, je click sur "commander" et j arrive sur une page blanche.

je recherché des reponses sur le forum ZentCart : http://www.zen-cart.com/forum
et j ai touvé comment trouver l erreur : en installant le module Debug Error-Logging : http://www.zen-cart.com/index.php?main_page=product_contrib_info&products_id=860

voici la réponse que le module me donne:

[24-Feb-2009 11:27:36] PHP Warning:  shipping(includes/modules/shipping/chronopost.php) [<a href='function.shipping'>function.shipping</a>]: failed to open stream: No such file or directory in /homez.31/unapolog/www/supporteurope/shop/includes/classes/shipping.php on line 54

[24-Feb-2009 11:27:36] PHP Warning:  shipping() [<a href='function.include'>function.include</a>]: Failed opening 'includes/modules/shipping/chronopost.php' for inclusion (include_path='.:/usr/local/lib/php') in /homez.31/unapolog/www/supporteurope/shop/includes/classes/shipping.php on line 54

[24-Feb-2009 11:27:36] PHP Fatal error:  Cannot instantiate non-existent class:  chronopost in /homez.31/unapolog/www/supporteurope/shop/includes/classes/shipping.php on line 56


je suis encore un debutant en php ...  qq'un pourait - il me traduire les erreurs et comment les resoudres


merci pour ton attention
saludos,

--Morgan
Journalisée
vincent109
Nouveau membre
*

Points gagnés: 0
Messages: 1


Voir le profil
Re : Quasi Résolu !! Problème avec checkout_shipping et chronopost.php
« Répondre #1 le: 25 Mars 2009 à 18:50:17 »

Bonjour mchamps013,
 j'ai le meme pb que toi, install de la boutique (version 1.3.8a) nickel et tout et tout, puis en phase test d'un achat, apres la creation de mon compte >>> hop page blanche.

Je reviens en arriere, je rajoute des produits au panier, et des que je clique sur commander >>> hop page blanche.

Je vais tester le petit module de debug que tu as indiqué, on verra si j'ai les memes reponses que toi.

Je me permet de te soliciter parceque j'ai vu que ta boutique avait l'air de fonctionner correctement, donc peut etre as-tu trouver les raisons et solutions du probleme.

Par avance merci






Journalisée
feerepart
Nouveau membre
*

Points gagnés: 0
Messages: 10


Voir le profil
Re : Quasi Résolu !! Problème avec checkout_shipping et chronopost.php
« Répondre #2 le: 17 Juin 2009 à 21:19:45 »

bon ben pour moi c'est pareil, suite à la création de compte ou suite à "commande" je me trouve sur une page blanche...
apparement on est plusieurs dans ce cas mais je n'ai pas encore trouvé un topic où une réponse apparait... snif
Journalisée
jean-luc
Modérateurs
Intarissable
*****

Points gagnés: 3
Messages: 1561



Voir le profil WWW
Re : Quasi Résolu !! Problème avec checkout_shipping et chronopost.php
« Répondre #3 le: 17 Juin 2009 à 21:29:51 »

Bonsoir,

je n'ai pas fait de recherche particulière dans le forum, mais je pense avoir déjà lu/répondu à ce genre de question, à priori au vu de ce qui ressort des erreurs soit il manque un fichier soit le module chronopost n'est pas correctement configuré, mais je pencherai plutôt pour la première solution

Journalisée

jean-luc Evil or Very Mad

pas bon, mais promis j'essaye de m'améliorer tous les jours Evil or Very Mad

www.anneg-lingerie.com
gob33
Acharné
****

Points gagnés: -1
Messages: 264


Voir le profil
Re : Quasi Résolu !! Problème avec checkout_shipping et chronopost.php
« Répondre #4 le: 17 Juin 2009 à 23:26:09 »

Au lieu de faire des supputations à la noix, il y a plein de précisions à apporter:
1) Quel est la version complète installée du module Chronopost.
2) Si tu désinstalles le module et effaces les ficiers, est-ce que ça remarche ?
3) Est-ce que le popup "shipping_estimator" marche (juste avant 'commander') ?
4) Pourquoi les autres utilisateurs de Chronopost n'évoquent pas ce pb en masse s'il y a, et que tu sois seul ?
5) Quelle est la dernière modif/saisie que tu as fait ? (souvent cause de l'erreur)
6) Est-ce que t'as pas oublié un point-virgule ou une parenthèse en dernière saisie ?
« Dernière édition: 14 Octobre 2009 à 13:12:54 par gob33 » Journalisée

nathalie
Nouveau membre
*

Points gagnés: 0
Messages: 7


Voir le profil
Re : Quasi Résolu !! Problème avec checkout_shipping et chronopost.php
« Répondre #5 le: 22 Juillet 2012 à 22:35:37 »

Je réponds à ce topic parce que j'ai eu ce même souci
et l'ai réglé en allant voir dans l'administration
Module > Livraison
c'est un des modules de livraison qui "déconne"
Journalisée

Pages: [1]
  Imprimer  
 

Aller à: