Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre courriel d'activation?
*


ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???


Pages: [1]
  Imprimer  

  ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
Auteur Message
Emma
Modérateurs
Espoir
*****

Points gagnés: 0
Messages: 238


Voir le profil WWW
ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
« le: 03 Juin 2008 à 21:36:06 »

Bonsoir

Je viens de lire ceci :
http://www.zen-cart.com/forum/showthread.php?t=72869
Daté du 12 juillet 2007, annonçant que la version de Zen-cart 1.4 sera incompatible avec PHP 4, mais compatible PHP 5. Et que la version 1.3.8 continuerait de tourner sous PHP 4.3.2 pendant les 6 mois suivant la nouvelle version ZC 1.4 (enfin, j'me suis p'tête gourée dans la traduction, hein...)

Heuuu, y a quelqu'un qui peut m'expliquer l'intérêt d'installer une version 1.3.8, alors que mon hébergeur est déjà sous PHP 5 depuis pas loin d'un an et demi ????? Et la version ZC 1.4 n'est toujours pas sortie ????
Je comprends mieux mes soucis avec mon TPE CIC, du coup. Rolling Eyes

Bon, je fais quoi, maintenant que je sais que mon site, sur lequel je bosse depuis des mois et que je suis censée ouvrir cette semaine, n'est pas compatible avec PHP 5 ? Je passe chez OsC ?  Evil or Very Mad
Merde, merde, merde !!!!!

Désolée pour la mauvaise humeur... Si vous avez une bonne nouvelle pour me la faire passer, j'suis preneuse.... Sad
Journalisée
jean-luc
Modérateurs
Intarissable
*****

Points gagnés: 3
Messages: 1561



Voir le profil WWW
Re : ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
« Répondre #1 le: 03 Juin 2008 à 21:59:29 »

Bonsoir,

La bonne nouvelle s'est qu'en effet il y a erreur, la 1.388 continuera à fontionner sous php4, mais ce qui ne durera que 6 mois c'est la maintenance par le team US de ZC

allez, pleure plus tu peux le mettre en ligne ton site... Laughing
Journalisée

jean-luc Evil or Very Mad

pas bon, mais promis j'essaye de m'améliorer tous les jours Evil or Very Mad

www.anneg-lingerie.com
Emma
Modérateurs
Espoir
*****

Points gagnés: 0
Messages: 238


Voir le profil WWW
Re : ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
« Répondre #2 le: 03 Juin 2008 à 22:04:48 »

Heuuuuu, j'vois pas bien ce qu'il y a de drôle, parce que mon hébergeur est déjà sous PHP5 depuis un an et demi , si tu me relis bien Rolling Eyes
Journalisée
damien
Administrateurs
Acharné
*****

Points gagnés: 4
Messages: 365


Voir le profil WWW
Re : ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
« Répondre #3 le: 04 Juin 2008 à 21:30:00 »

Bonsoir,

Je te rassure aussi, ce que dit ce post en résumé, c'est que :
- Zen Cart v1.4.0 nécessitera PHP 5.2 pour bien fonctionner
- Zen Cart v1.3.x aura toujours des mises à jour (de sécurité notamment) pendant 6 mois après la sortie de la 1.4.0

Mais Zen Cart 1.3.8 est compatible PHP4 et PHP5 et le restera pour sa part. Je ne vois donc pas pourquoi vous devriez laisser tomber votre site qui tourne sur zen cart 1.3.8 + PHP 5, puisque c'est et ça restera compatible. Vous avez dû mal comprendre en traduisant (?)
Journalisée

Cordialement,
Damien
Emma
Modérateurs
Espoir
*****

Points gagnés: 0
Messages: 238


Voir le profil WWW
Re : ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
« Répondre #4 le: 05 Juin 2008 à 22:45:36 »

Bonsoir

Merci de ta réponse.

J'avais bien précisé que je n'étais pas sûre de ma traduction  Wink

Bon, ceci dit, ça ne règle toujours pas mon souci avec le TPE, et là, ça commence à urger vraiment, donc, soit je trouve une soluce qui tient vraiment la route, soit je refais le tout sous OsCommerce, ce qu'ont fini par faire certains qui n'ont trouvé ni où et comment ça buguait, ni aucune aide en la matière...
Il semblerait que rares (voire plus que rares) sont les sites qui proposent le paiement CM-CIC, donc, j'en viens à me dire qu'il n'y a pas de soluce entre ZC et le TPE CM-CIC, auquel cas le problème est réglé en ce qui me concerne, il est hors de question que je propose un paiement paypal à mes clients.
Question de choix... et surtout de sérieux.

Cordialement,
Emma.

PS : Quid de la version 1.3.8 en français lors de la maj vers la version 1.4 ? Ca se passera comment pour la BD ?
Journalisée
jean-luc
Modérateurs
Intarissable
*****

Points gagnés: 3
Messages: 1561



Voir le profil WWW
Re : ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
« Répondre #5 le: 16 Juin 2008 à 22:01:25 »

Bonsoir,Cmcic fonctionne très bien avec Zencart, mais le développement est un peu compliqué et m'a couté relativement cher, mais en revanche y a pas photo par rapport aux autres solutions de paiement, j'ai aussi SPPlus pour le paiement en 3 fois que ne propose pas cmcic mais l'interface de gestion des paiements est à ch... , donc courage mon install de cmcic date de plus deux ans maintenant et fonctionne sans problème elle a été directement adaptée de celle d'OScommerce car il n'en existait pas sous ZC à cette époque et j'utilisais déjà cmcic sur ma précédente plateforme (minivend, une rolls mais très complexe), donc si tu as des soucis pose toujors les quesions si on peut y apporter une réponse ce sera avec plaisir  Laughing
Journalisée

jean-luc Evil or Very Mad

pas bon, mais promis j'essaye de m'améliorer tous les jours Evil or Very Mad

www.anneg-lingerie.com
Emma
Modérateurs
Espoir
*****

Points gagnés: 0
Messages: 238


Voir le profil WWW
Re : ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
« Répondre #6 le: 16 Juin 2008 à 23:39:50 »

Re-bonsoir Wink

C'est très sympa de proposer un coup de main, je dois dire que je commençais à désespérer  Confused
J'ai testé plusieurs trucs : utiliser le module en téléchargement sur zen-cart.com (en suivant à la lettre la procédure, toussa, toussa), ça ne marchait pas, donc je suis allée chercher le module d'OsC, mais j'arrive au même résultat, à savoir message d'erreur :
Fatal error: Call to a member function Execute() on a non-object in /monsite.com/cmcic_response.php on line 39. 
J'ai ensuite bidouillé histoire de passer les messages d'erreur qui se succédaient, pour arriver à un "Illegal Access", sauf que je n'ai pas pu identifier d'où il venait.
J'ai ajouté les fichiers database.php et general.php (dans /includes/functions), ajouté les lignes correspondantes dans database_tables.php, j'ai bien les deux tables cmcic_reference (qui prend bien les enregistrements) et cmcic_response (qui ne prend aucun enregistrement)...
Là, j'y perds mon latin php... Sad
Ca aurait peut-être été plus simple de choisir un autre système... sauf que ma banque est le CIC, et que je ne pensais vraiment pas galérer comme ça.

Bref, je serais vraiment trèèèèèèèèèès contente d'avoir de l'aide ! Smile

Journalisée
jean-luc
Modérateurs
Intarissable
*****

Points gagnés: 3
Messages: 1561



Voir le profil WWW
Re : ZC1.3.7 ou 1.3.8 et PHP 5 : Incompatibilité ???
« Répondre #7 le: 18 Juin 2008 à 17:58:48 »

Bonjour,

Si le webmaster en a la possibilité ça serait bien de balancer les 2 ou 3 derniers post conncernant Cmcic vers le bon sujet, je vais donc te répondre dans la bonne rubrique
Journalisée

jean-luc Evil or Very Mad

pas bon, mais promis j'essaye de m'améliorer tous les jours Evil or Very Mad

www.anneg-lingerie.com

Pages: [1]
  Imprimer  
 

Aller à: